iOS 导航SDK 如何解决引入AMapNaviKit提示“_OBJC_CLASS_$_MAMultiTexturePolylineRenderer”错误的问题?

出现该错误是由于引入的3D地图SDK的版本太低,解决该问题请参考以下步骤:

1、打开 AMapNaviKit.framework 中的 AMapNaviVersion.h。

2、定义的 AMapNavi3DMapVersionMinRequired 的宏表示需要的最低的3D地图SDK的版本,每两位表示对应的版本号,首位0省略,40200表示 4.2.0。

3、前往相关下载下载所需版本的3D地图SDK。


如以上内容仍未解决您的问题,请创建工单
新用户
福利
示例
中心
常见
问题
智能
客服