您现在的位置: 开发 > Flutter插件 > 概述

概述 最后更新时间: 2021年11月23日

Flutter插件简介

Flutter是谷歌的移动UI框架,可以快速在iOS和Android上构建高质量的原生用户界面,因其毫秒级热重载能够实现快速开发、具备超强原生性能以及富有表现力和灵活的UI,越来越受开发者喜爱,因此推出高德定位和地图Flutter插件供广大开发者在开发Flutter Application的时候,可以集成本插件实现基本定位需求。

温馨提示:建议在产品下载页面,下载已集成本插件的Flutter Application工程Demo进行参照,推荐使用Android Studio进行Flutter开发,集成插件前需先搭建好Flutter环境。 

重要:由于个人信息保护法的实施,Flutter插件3.0.0版本已发布,主要增加隐私适配接口,请配合Android定位SDK5.6.0、iOS定位SDK2.8.0及以上版本和地图SDK8.1.0及以上版本进行合规适配。

定位Flutter插件合规接口:

AMapFlutterLocation.updatePrivacyShow和AMapFlutterLocation.updatePrivacyAgree

地图Flutter插件合规声明在创建AMapWiget时传入,key值为:privacyStatement

示例
中心
常见
问题
智能
客服