您现在的位置: 开发 > Android 定位SDK > 开发指南 > 创建工程 > 开发注意事项

开发注意事项 最后更新时间: 2021年11月01日

添加高德 Key

为了保证高德 Android SDK 的功能正常使用,您需要申请高德 Key 并且配置到项目中。

项目的 “AndroidManifest.xml” 文件中,添加如下代码:

<application
         android:icon="@drawable/icon"
         android:label="@string/app_name" >
         <meta-data
            android:name="com.amap.api.v2.apikey"
            android:value="请输入您的用户Key"/>
            ……
</application>

隐私合规接口说明:

1.定位的合规接口说明如下:

/** 设置包含隐私政策,并展示用户授权弹窗 <b>必须在AmapLocationClient实例化之前调用</b>
	 *
	 * @param context
	 * @param isContains: 是隐私权政策是否包含高德开平隐私权政策  true是包含
	 * @param isShow: 隐私权政策是否弹窗展示告知用户 true是展示
	 * @since 5.6.0
	 */
	public static void updatePrivacyShow(Context context, boolean isContains, boolean isShow); 
/**
 * 设置是否同意用户授权政策 <b>必须在AmapLocationClient实例化之前调用</b>
 * @param context
 * @param isAgree:隐私权政策是否取得用户同意  true是用户同意
 *
 * @since 5.6.0
 */
public static void updatePrivacyAgree(Context context, boolean isAgree) ;

2.在构造AMapLocationClient 之前必须进行合规检查,设置接口之前保证隐私政策合规,检查接口如下:

AMapLocationClient.updatePrivacyShow(context,true,true);
AMapLocationClient.updatePrivacyAgree(context,true);

3.构造AMapLocationClient调用时要捕获异常信息,具体方式可参考如下

try {
mClient = new AMapLocationClient(context);
}catch (Exception e){
}

4.并在使用mClient的时候,请进行空指针判断,确保可以使用;

if (mClient != null){
// TODO
}

代码混淆

在生成 apk 进行代码混淆时进行如下配置(如果报出 warning,在报出 warning 的包加入类似的语句:-dontwarn 包名)

    3D 地图 V5.0.0之前:
    -keep   class com.amap.api.maps.**{*;} 
    -keep   class com.autonavi.amap.mapcore.*{*;} 
    -keep   class com.amap.api.trace.**{*;}

    3D 地图 V5.0.0之后:
    -keep   class com.amap.api.maps.**{*;} 
    -keep   class com.autonavi.**{*;} 
    -keep   class com.amap.api.trace.**{*;}

    定位
    -keep class com.amap.api.location.**{*;}
    -keep class com.amap.api.fence.**{*;}
    -keep class com.loc.**{*;}
    -keep class com.autonavi.aps.amapapi.model.**{*;}

    搜索
    -keep   class com.amap.api.services.**{*;}

    2D地图
    -keep class com.amap.api.maps2d.**{*;}
    -keep class com.amap.api.mapcore2d.**{*;}

    导航
    -keep class com.amap.api.navi.**{*;}
    -keep class com.autonavi.**{*;}

兼容性

支持 Android 2.3 及以上系统。


新用户
福利
示例
中心
常见
问题
智能
客服